I suppose after making the 500+ mile trip in the Yugo, I had sort of managed to convince myself that, incredibly, this old, free Yugoslavian shitbox was, somehow, a reliable and useful little car. I mean, I still think it is surprisingly tough for what it is, but I may have gotten overconfident about how trouble-free this Yugo might be. That blind confidence got slapped with a little dose of reality and interior smoke yesterday.

I was driving with my kid to the grocery store in the Yugo last night, when I noticed some wisps of magic electrical smoke wafting up from somewhere in front of me. Behind the dash? From the vents? I couldn’t really tell, but things didn’t smell great, so I found a parking lot to pull into.

Once stopped, I began to hunt for the source of the smoke, and soon found it, under the dashboard. I got down on my knees and saw the problem: the brake light switch, mounted to the brake pedal assembly, was pumping out consistent tendrils of smoke, and seemed to be, um, melting.

Advertisement

In fact, the white plastic middle of the switch did melt into goop, dropping off the upper part of the switch sloppily, with the same languid submission of a scoop of ice cream melting and dropping heavily off a cone on a hot summer day. This was the result:

Advertisement

In that little video, you can see the yellowish goop that is the remains of that half of the switch, and the bit with the terminals is the smoking part in my hand.

Clearly, something’s up. Now, I have no idea what happened between yesterday when everything was fine, and this, but somewhere in that miserable rat’s nest of wiring some bare bit of wire must be grounding to somewhere it shouldn’t be, or something like that.

Advertisement

The only clue I have is that at first in the trip the radio had no power, then, for no clear reason, it all of a sudden did again. Some bit of awful wiring must have shifted or broken or moved that caused this chain of events to happen, I guess.

I don’t have the proper switch to replace it just yet, but for safety reasons I wanted to do some kind of temporary fix, so I dug around my piles of crap and found a switch that looked like it’d work.

Advertisement

I checked the voltage on the wires and found it to be 14.7 or so volts with the engine running—maybe a bit on the high side, but I think within reason. For some reason my meter wasn’t giving me a good reading on the amps, so I need to check that out still.

Advertisement

I alligator clipped the brake light leads to this beefy leaf switch I had, and clamped that to the high/low beam lever, where I can use it as a manually-actuated brake light switch. It’s hardly ideal, but it’s better than nothing, and I can feel if it’s getting hot. If it does, the alligator clips make it very easy to rapidly disconnect.

Advertisement

So, I guess my next step is to start digging around in this mess of an electrical system. I have to get the wipers working again, anyway, after all.

Advertisement

I’m not really looking forward to starting this project, because I’m just about certain I’ll be confronted with a baffling mess of wires and tape and splices and patches and things that only make logical sense with the judicial application of a lot of hallucenogens.

It can’t be that complicated of an electrical system, though, right?

Right?!